RHEL7b1 PXE network install and the kssendmac option

Tuesday , 17, December 2013 4 Comments

So my first test of RHEL7b1 was "interesting" in a sense that anaconda died on me with a "dracut Warning: /dev/root does not exist" message.

Instead of using the DVD.iso to setup a VM, I just added the rhel7b1 tree on my home nfs server and I quickly copied/pasted some lines in my pxe default.cfg boot menu (and just changed the path to kernel/initrd.img). So, I had a quick look at the documention (and also at the isolinux/isolinux.cfg file on the DVD) and I noticed several things :

- anaconda "usual" options are now inst.${previous_feature} (so inst.repo when it was just repo for previous RHEL releases) -> time to read the doc 

- some previous options aren't supported anymore : for example I used (in the past) the kssendmac feature, and I forgot to remove it from pxe default.cfg line , and that was the parameter that made anaconda dying on me. (for example https://bugzilla.redhat.com/show_bug.cgi?id=987657 and https://bugzilla.redhat.com/show_bug.cgi?id=844478 )

Removing that kssendmac boot option was the way to go, now time to write my first EL7 kickstart files to be ready for QA when it will be built ­čÖé

4 thoughts on “ : RHEL7b1 PXE network install and the kssendmac option”
  • koizumi says:

    I also encountered the same error.
    "/dev/root does not exit."
    I burned rhel-everything-7.0-beta-1-x86_64-boot.iso to my 4GB USB flash and booted from it.
    What's wrong with me ?

  • koizumi says:

    Self resolved.

    I changed 90-anaconda.rule file under /etc/udev/rules.d/ with /bin/sed so that the label matches with the USB.
    or
    Be sure the label is "RHEL-7.0\x20x86_64" before the installation,.

  • For the CentOS 7 release, the label needs to be "CentOS 7 x86_64".

    "disk/by-label/CentOS\x207\x20x86_64"

  • ReverandABomb says:

    I found this post via Google after I got the same error and wanted to share my experience to help those that will follow...

    My PXE boot configuration is similar and got the same error at the end. To fix, change --ksdevice=ethX to read --ks.device=ethX or, even better, --ks.device=link

    http://fedoraproject.org/wiki/Anaconda_Boot_Options

  • Please give us your valuable comment

    Your email address will not be published. Required fields are marked *