Updated CentOS Vagrant Images Available (v1608.01)

Wednesday , 7, September 2016 3 Comments

UPDATE 2016-09-08: Due to additional checks, we had to retire v1608.01 from Atlas and release it again as v1608.02. The two versions are identical.

Official Vagrant images for CentOS Linux 6 and CentOS Linux 7 for x86_64 are now available for download, featuring updated packages to 31 August 2016, as well as a new image for VMware Fusion.

Known Issues

  1. The VirtualBox Guest Additions are not preinstalled; if you need them for shared folders, please install the vagrant-vbguest plugin. We recommend using NFS instead of VirtualBox shared folders if possible.
  2. Since the Guest Additions are missing, our images are preconfigured to use rsync for synced folders. Windows users can either use SMB for synced folders, or disable the sync directory by adding the line config.vm.synced_folder ".", "/vagrant", disabled: true to the Vagrantfile.
  3. Vagrant 1.8.5 is unable to create new Linux boxes due to Vagrant bug #7610. You can use Vagrant 1.8.4 until version 1.8.6 is released.
  4. The VMware Tools installer fails to generate a new initramfs due to a dracut configuration error in both our image and VMware Tools. As a workaround, change the add_drivers line in /etc/dracut.conf.d/vmware-fusion-drivers.conf to
    add_drivers+=" mptspi "

    (add spaces directly before and after mptspi) before trying to install VMware Tools or open-vm-tools.

Downloads

The official images can be downloaded from Hashicorp's Atlas. We provide images for libvirt, VirtualBox and VMware.

If you never used our images before:

$ vagrant box add centos/6 # for CentOS Linux 6
$ vagrant box add centos/7 # for CentOS Linux 7

Existing users can upgrade their images by:

$ vagrant box update --box centos/6
$ vagrant box update --box centos/7

Checksums

The downloaded images should have the following SHA256 checksums:

914ab02db12f2d19f71dbd3c6cb171dff683893443e26f2f03160491945366dc  CentOS-6-x86_64-Vagrant-1608_01.LibVirt.box
5391ea7bdafafe8d8df58b8405d81cafdcd0b8273c18cdd37133dcf1cb329a0b  CentOS-6-x86_64-Vagrant-1608_01.VirtualBox.box
4d6a5906ada93a5228f62671f7c97bed0ae3c961df108c25ceee278a8d9d17d2  CentOS-6-x86_64-Vagrant-1608_01.VMwareFusion.box
2916442968486a41315cb93d35fbbaeaf72e200f051f4996b5766649b8c3a325  CentOS-7-x86_64-Vagrant-1608_01.LibVirt.box
415b79487cdb7e0246ef93585de08d2063b1e7b85ff5666f60de5cb96a4a027c  CentOS-7-x86_64-Vagrant-1608_01.VirtualBox.box
44d26155e89fa5d74994167489bd66da4187b3da02ac3a063f0b26cfab965baf  CentOS-7-x86_64-Vagrant-1608_01.VMwareFusion.box

Vagrant has the ability to verify that the downloaded image has a specific checksum, e.g.

$ vagrant box add --checksum-type sha256 --checksum 2916442968486a41315cb93d35fbbaeaf72e200f051f4996b5766649b8c3a325 --provider libvirt centos/7

Unfortunately, this is not possible with vagrant box update.

Feedback

If you encounter any unexpected issues with the Vagrant images, feel free to ask on the centos-devel mailing list, or in #centos-devel on Freenode.

3 thoughts on “ : Updated CentOS Vagrant Images Available (v1608.01)”
  • Hanley Hansen says:

    I purchased the vagrant VMWare Fusion plugin and whenever I try to bring up a `centos/7` box I get the following error:

    ==> base: Rsyncing folder: /Users/hanleyhansen/GDrive/Work/Projects/git/vjvit-cm/vagrant/ => /vagrant
    ==> base: Waiting for HGFS to become available...
    HGFS was never found on the running virtual machine. This must be
    installed either through VMware tools or Open VM Tools. HGFS is
    required for shared folders to work properly. Please install either
    the VMware tools or Open VM Tools and try again.

    • Laurențiu Păncescu says:

      I'm not using VMware at all, so the following is rather theoretical.

      The error message is only related to the shared folders. You should be able to connect to the box via "vagrant ssh" and install one of the suggested packages (e.g. "sudo yum install open-vm-tools", since Open VM Tools are in the official CentOS repos). You can then reboot the box with "vagrant reload", and the error should disappear.

  • Rafal Skolasinski says:

    Vagrant 1.8.6 is already released and there is no problem with creating boxes anymore.

  • Please give us your valuable comment

    Your email address will not be published. Required fields are marked *